Common Commands
Applicability: Cranium, Synapse

Cranium and Synapse each use a set of documents to manage data, estimates, references, structures, etc. as well as provide key functionality. Cranium's documents provide functionality for data management, physical property estimation, graphing, bookmarking and reporting. Synapse's include these plus documents for the selection and design of new chemicals and mixtures.

The functionality associated with each document is accessed using the menubar and the toolbar.

The commands found on the Commands menu are different for each document chapter. For example, the Commands menus for the Knowledge Base's Chemicals chapter and the Chemical Design Document's Combinatorials chapter are shown here.

(commands on Commands menus are specific for each chapter)

The remaining menus are common to all documents used by Cranium and Synapse.

File Menu Commands

The File menu contains commands to open, save, print and copy document files.

Each of the File menu's commands are described below.

  • New: creates a new document. The command activates the New Document dialog enabling you to specify the name and location of the new document. The new file is created and the document is opened within the application.
  • Open: opens an existing MKS document. The command activates the Open File dialog enabling you to select the specific document you wish to open.
  • Close: closes the active, i.e., top-most, document. Since all values are saved into documents at the conclusion of editing, a document never contains any unsaved data. Thus, there is no need for a "Save Document".
  • Save a Copy: makes a duplicate of the currently active, i.e., top-most, document. This command is used often to create backups and archival copies as well as to create new documents for experimentation and projects. See documentation on Copy Document for additional details.
  • Compare Documents: displays the property values that are present in one knowledge base but not in another. This command is very useful for determining what are the differences between two versions of the same document. See documentation on the Compare Documents Dialog for additional details.
  • Convert Document: enables you to convert an MKS document in an older format into an MKS document in the newest format. See documentation on the Convert Document Dialog for details.
  • Import Values: enables you to copy values from other documents and paste them into the current document. This command is not available for all document types. See documentation on the KB Import Dialog for details on importing values into MKS knowledge bases.
  • Export Values: enables you to transfer values from the current document into other documents, even non-MKS formatted documents such as text files an process simulator input files. See documentation on the
  • Page Setup: enables you to specify margins, orientation and paper size for printed output. See documentation on the Page Setup Dialog for details.
  • Print Preview: activates the Print Sections dialog enabling you to select which sections you wish to preview. The sections are displayed in the active document's view. See documentation on the Print Sections Dialog for details.
  • Print: activates the Print Sections dialog enabling you to select which sections you wish to print. The sections are displayed in the active document's view. See documentation on the Print Sections Dialog for details. Once you select the sections you wish to print, the application will activate the Print dialog enabling you to specify printer options.
  • Cranium and Synapse will append the names of the last few opened documents to the end of the File menu. Clicking on any of these names will open the document.
Edit Menu Commands

The Edit menu contains commands for performing various editing functions including adding and removing pages, undoing previous edits, duplicating and inserting pages and accessing the ScratchPad dialog.

Each of the Edit menu's commands are described below.

  • Undo: undoes the last edit action. Note that not all edit actions can be undone. Such actions, like deleting a document page, typically display a dialog notifying you that an action cannot be undone.
  • Delete Current Page: removes the current page from the current document. Note that this edit action cannot be undone.
  • Add New Page: adds a new blank page to the current document.
  • Duplicate Current Page: adds a new page to the current document and copies all values from the current page onto this new page. (This command is very convenient for experimentation.)
  • Insert Pages: copies one or more pages from another open document and inserts them into the current document. See documentation on the Insert Entity Dialog for additional details.
  • Scratchpad: activates the Scratchpad dialog which provides functionality for editing and arranging values for pasting into MKS documents. See documentation on the Scratchpad Dialog for details.
Navigation Menu Commands

Navigating through Cranium and Synapse primarily involves changing chapters and turning pages. The Navigation menu provides commands for navigating to the first page, last page, next page, previous page as well as going to specific page and scanning through all the pages in a chapter.

Each of the Navigation menu's commands are described below.

  • Page Forward: moves one page forward in the current chapter.
  • Page Back: moves one page backward in the current chapter.
  • First Page: moves to the first page in the current chapter.
  • Last Page: moves to the last page in the current chapter.
  • Next Value: enables you to move forward or backward to a page containing values for a selected physical property. See documentation on the Next Value Dialog for details. (Note that this command is only available for knowledge base documents.)
  • Prior Page: returns you to the page you were viewing before you viewed the current page.
  • Go To: activates the Go To Entity dialog enabling you to select the entity you wish to page to by identifier or another attribute. See documentation on the All Entities Dialog and the All Groups Dialog for additional details.
  • Sort: activates the Sort Attribute dialog enabling you to sort all entities in the current chapter by a selected attribute. (Note that this sorted order is not permanent. The chapter will not be sorted the next time you open the document.) See documentation on the Sort Attribute Dialog for details.
  • Scan: moves forward page by page displaying all entities in the current chapter.
Bookmarks Menu Commands

Bookmarks are simply lists of entities that can be used for selection and navigation. For example, if you wish to examine the vapor pressures of all disulfides in your knowledge base, you would:

  1. Compile chemicals containing a -S-S- group.
  2. Save these groups into a bookmark set.
  3. Select this bookmark set for navigation.
  4. Scroll to the Chemicals Chapter's vapor pressure field.
  5. Use the Bookmarks menu or toolbar buttons to navigate to each bookmarked chemical.

See documentation on Using Bookmarks and the Bookmark Chapter for additional details.

Each of the Bookmarks menu's commands are described below.

  • Select Bookmark Set: activates the Select Bookmark dialog that enables you to choose a bookmark set to use for navigating the current document. See documentation on the Select Bookmark Dialog for details.
  • Next Bookmark: navigates to the page displaying the next bookmarked entity or, if the bookmarked entity is a document, opens the bookmarked document.
  • Previous Bookmark: navigates to the page displaying the previous bookmarked entity or, if the bookmarked entity is a document, opens the bookmarked document.
  • First Bookmark: navigates to the page displaying the first bookmarked entity or, if the bookmarked entity is a document, opens the bookmarked document.
  • Last Bookmark: navigates to the page displaying the last bookmarked entity or, if the bookmarked entity is a document, opens the bookmarked document.
  • Allow Duplicate Bookmarks: this option determines whether or not duplicate entries are allowed when a new bookmark is added to a bookmark set.
  • Bookmark All Entities: creates a bookmark for every entity in the current chapter.
  • Bookmark Document: creates a bookmark for the current document. Document bookmarks are used to open specified files.
  • Unbookmark Entity: removes the current entity from the currently selected bookmark set.
  • Bookmark Entity: adds the current entity to the currently selected bookmark set.
  • Goto Bookmarked Entity: activates the Goto Bookmarked Entity dialog enabling you to select an entity from the currently selected bookmark set. See documentation on the Goto Bookmark Dialog for details.
  • Scan Using Bookmark: activates the Scanning dialog that controls the speed with which the application navigates to each entity in the currently selected bookmark set. See documentation on the Bookmark Scanning Dialog for additional details.
Commands Menus

The commands found on the Commands menu are different for each document chapter. See the documentation on each chapter for details about each command.

Window Menu Commands

The Window menu provides commands for arranging and activating the currently open documents.

Each of the Window menu's commands are described below.

  • Arrange Icons: places the icons of minimized document windows along the bottom of the main application window.
  • Cascade: arranges the widows in stacked pattern starting at the main window's upper left corner and moving toward the lower right corner.
  • Tile: places the windows next to each other such that all windows can be viewed at once.
  • Toolbar: option for toggling the display of the toolbar located near the top of the application's main window.
  • Status Bar: option for toggling the display of the status bar located near the bottom of the application's main window.
  • The names of the open documents are appended to the bottom of the Window menu. Selecting a document's name will activate its window. This functionality is very useful when you many documents open at once.
Options Menu Commands

The Options menu provides commands general application options such as data file location, number formatting and property units.

Each of the Options menu's commands are described below.

  • Set Data Folder: enables you to select the default folder for opening and saving documents. Note that windows will also set the application's default folder typically to the last folder from which a document was opened.
  • Number Format: activates the Number Format dialog which enables you to specify how numerical values appear within the application. See documentation on the Format Dialog for details.
  • Set Units: activates the Set Property Units dialog that enables you to specify the units of measure for each property. Property units are set for the entire application, i.e., all documents use the same set of units.
Help Menu Commands

The Help menu provides commands which provide documentation as well as other general utility functions, e.g., math calculations and units conversion.

Each of the Help menu's commands are described below.

  • Check for Application Updates: activates the Application Upgrade Check dialog which will tell you if minor or major upgrades are available for your application. See documentation on the MKS Updater Dialog for details.
  • Show Product Documentation: shows online documentation for the current application.
  • Show Chapter Documentation: shows online documentation for the current chapter.
  • Show Documentation Index: shows the index of all online documentation.
  • Getting Started: shows documentation giving a basic introduction to Cranium and Synapse.
  • Set Documentation Location: typically all MKS documentation in online within the MKS website. This command enables you to change the location of this documentation if it is necessary to use offline documentation or a local server for documentation.
  • Reload Documentation Index: when Cranium and Synapse start, they load an index of all online documentation. If an internet connection is not available at startup, you can use this command to load the index at a later time.
  • Abbreviations: activates the Abbreviations dialog which explains the meaning of the various abbreviations used throughout Cranium and Synapse. See documentation on the Abbreviations Dialog for details.
  • Convert Units: activates the Units Conversion dialog which enables you to convert between the various units of measure used in Cranium and Synapse. This dialog is very handy when entering estimation techniques because all techniques must return their estimates in standard units.
  • Calculator: activates the Calculator dialog which enables you to make quick mathematical calculations.
  • About: displays the initial splash screen of the current application. This is useful for identifying the version information of the current application.
  • MKS Website: displays the Molecular Knowledge Systems website in your default browser.
  • Contact Us: initializes an email message that can be used to contact us.
Related Documentation
Topic Description
Estimating Chemical Properties a short video demonstrating how to estimate the physical properties of pure chemical using either Synapse or Cranium.
Estimating Mixture Properties a short video demonstrating how to estimate the physical properties of mixtures using either Synapse or Cranium.
Getting Started using Cranium provides a quick tour of Cranium's capabilities including physical property estimation and a discussion of structure editing.
Getting Started using Synapse provides a quick tour of Synapse's capabilities including a examples of chemical product design.