Comparing Documents
Applicability: Cranium, Synapse

It is often common, and frequently recommended, to make copies of knowledge base documents. One common situtation is to copy and archive a source knowledge base used in a selection or design project along with the selection and design documents. By making a copy, you immediately document all the physical property values used in your decision process.

When you have copies of a knowledge base, it is often neccessary to determine the differences between the copies. The Compare Documents dialog can show differences between the values contained in two knowledge bases.

1
Source Knowledge Base: this is typically taken to be the "older" or "original" knowledge base.
2
Target Knowledge Base: this is typically taken to be the "newer" or "updated" knowledge base.
3
Updated Values Table: lists all values that are present in the target document but not present in the source document.
4
Detail Button: activates the Detailed Record Values dialog which displays information about the selected record that is present in the target document but not in the source document.
Tip: Understand how to add and edit chemicals

You should understand how to add a new chemical and edit its properties before you work through the next example. See documentation on the Chemicals Chapter for a quick review.

Example: Compare two knowledge bases
  1. Open the MKS Core Knowledge Base document.
  2. Select the Save a Copy command from the File menu.
  3. The application will activate the Save As dialog. Enter a name for the document's copy, e.g., "MKS Core Knowledge Base - Target" and press the Save button.
  4. The application will activate a dialog displaying the progress of the copy operation. When the copying has completed, press the dialog's Open button.
  5. In the new target knowledge base, change to the Chemicals Chapter. (See the Navigation Overview documentation for details on navigating chapters and pages.)
  6. Create a new chemical by clicking on the "+" button in the menubar or selecting the Add New Page command from the Edit menu. The application will add and display a new, blank chemical.
  7. Click the left mouse button in the Identifier pane and enter a name for the new chemical.
  8. Click the left mouse button in the Formula field and enter a new, fictitious formula for the new chemical.
  9. Click the left mouse button the the MKS Core Knowledge Base's window to make it the topmost, active window. (The comparison algorithm looks for values present in the target document that are not in the source document. In this example, it is thus important that the original knowledge base be used as the source document.)
  10. Select the Compare Documents command from the File menu. The application will activate the Compare Data dialog.
  11. Press the dialog's Browse button and select the target document.
  12. Press the dialog's Compare button. The application will compare every value in the target document against every value in the source document. If the target value is not found it is reported in the dialog's Updated Values table.
  13. The dialog found the two new values we added to the target document: 1) the new identifier; 2) the new formula. Click the left mouse button on the formula row to select the row and press the dialog's Details button. The Details dialog is activated showing the new formula's values.
Related Documentation
Topic Description
Estimating Chemical Properties a short video demonstrating how to estimate physical properties using either Synapse or Cranium.
Getting Started using Cranium provides a quick tour of Cranium's capabilities including a discussion of structure editing.
Chemicals Chapter the chemicals chapter contains numerous sections for entering and displaying data and estimates including the chemical structure section.