Creating Graphs
Applicability: Cranium, Synapse

Graph documents provide extensive capabilities for creating, organizing and viewing physical property values in graphical formats. Both xy-graphs and triangular-graphs can be creating a large variety of data points, curve segments and regions.

Example: Create an xy graph
  1. Select the New command from the File menu. The application will activate the Create a New Document dialog. Select the Graph Document document type and press the dialog's OK button.
  2. The application will activate the File Dialog prompting you for the filename of the new document. Enter a name and press the dialog's Save button. The application will create and open the new graph document.
  3. Enter values for the document's title, subtitle and descriptions. See documentation on the Document Titles Section and Document Information Section for details.
  4. Using the tabs at the top of the document, change to the XY Graphs Chapter by clicking the left mouse button on the XY Graphs tab. (See the Navigation Overview documentation for details on navigating chapters and pages.)
  5. Create a new xy graph entity by pressing the "+" button in the menubar or executing the "Add New Page" command found on the Edit menu. A new, blank xy graph page will be added to the current document.
  6. Click the left mouse button on the Identifier Pane's edit control. The application will activate the edit dialog.
  7. Enter the name "Group Contribution Techniques, -CH2- (ss)". Optionally enter a reference and comment.
  8. Finally, press the dialog's Save button. The application will save the new design's identifier into the current document and display the new name you just entered.
Example: Editing XY Graph Data

The following table shows normal boiling point data for a series of cycloalkanes.

Chemical # CH2 Groups Tb [K]
Cyclopropane 3 240.4
Cyclobutane 4 285.7
Cyclopentane 5 322.4
Cyclohexane 6 353.9
Cycloheptane 7 391.9
Cyclooctane 8 424.3
Cyclononane 9 448.0
Cyclodecane 10 474.0
  1. Using the mouse, select and copy the values shown in the table above.
  2. Navigate to the xy graph we created in the previous example.
  3. Click the left mouse button on the XY Data Values Section's large table control. The application activates the Edit XY Data dialog.
  4. Click the left mouse button on the dialog table control's first row. The click the right mouse button. The application activates the table's commands menu.
  5. Select the Paste Special command from the commands menu. The application activates the Paste Special Mapping dialog.
    1
    Click the left mouse button in the edit control at the top of a column to assign an attribute to that column.
    2
    You must assign all required attributes to data columns.
  6. Click the left mouse button in the edit controls at the top of each data column and assign the following attributes:
    1. Label: chemical names column
    2. X Values: number of groups column
    3. Y Values: boiling points column
  7. Finally, press the Mapping dialog's OK button. The application will paste the values, in the selected order, into the edit dialog.
  8. Using the left mouse button, click on the first table row and drag downward to select all valued rows.
  9. Press the dialog's Set Segs (Set Segments) button. The application activates the Edit Data Segments dialog.
  10. Enter a value of "-CH2- (ss)" for the first segment and press the dialog's OK button. The application assigns the segments to all selected rows.
  11. Finally, press the dialog's Save button to store the entered data values into the current document.
Example: Add a curve segment

XY and triangular graphs display data in curve and region segments. Each curve or region segment displays a subset of data using symbols, lines, colors and borders. Only those data whose segments list contains a curve segment's or region segment's name are displayed when that segment is drawn on the graph.

  1. Navigate to the xy graph we created in the first example.
  2. Scroll down to the XY Segments Section. Click the left mouse button on the Curve Segments field's table control. The application activates the Edit Curve Segments dialog.
  3. Select the dialog table's first row and press the Edit button. The application activates the Edit Curve Segment dialog.
  4. Select "-CH2- (ss)" as the Segment Name and various values for the segment's Symbol Attributes. For this example, select the No Line option for the Line Type. Finally, press the dialog's OK button.
    1
    Select the segment's name. Only those data whose segments list contains this name will be displayed.
    2
    Select Symbol Attributes as desired.
    3
    For this example, select the No Line option so the data points are not connected by lines.
  5. Finally, press the Edit Curve Segments dialog's Save button to store the entered segment into the current document.
Example: Editing graph attribues

XY and triangular graphs have many attributes that can be edited. Axis limits, tick mark fonts, area colors, axis labels, notes, and scale are just some of the attributes that can be tailored for each graph.

The Graph Section displays the graph in a large control. Clicking the left mouse button on the graph control activates the Graph Attributes dialog that enables you to change the graph's numerous attributes.

  1. Navigate to the xy graph we created in the first example.
  2. Scroll down to the Graph Section. Click the left mouse button on the section's table control. The application activates the XY Graph Attributes dialog. Note that although we have entered data and specified a curve segment, nothing is displayed in the current graph.
    1
    Graphs are initially displayed with default attributes. The minimum and maximum limits for each axis are some of these default limits. So, if your entered data are not within these default limits, they will not be displayed initially. You will need to edit the axis limits to have them displayed.
  3. Press the dialog's X Label button. The application activates the Edit Axis Label dialog. Enter "Number of Carbons" in the Label Text control. Press the dialog's Font button and change the font attributes as desired. Finally, press the dialog's OK button.
  4. Press the Graph Attributes Dialog's X Axis button. The application activates the Edit Axis Attributes dialog. Press the minimum Find button and the maximum Find button. The application will respectively, insert the minimum data value and the maximum data value into the limits controls. Adjust the Axis Attributes controls as desired and press the dialog's OK button.
    1
    Pressing the minimum Find button inserts the minimum datum value into the minimum edit control.
    2
    Pressing the maximum Find button inserts the maximum datum value into the maximum edit control.
    3
    Use the Axis Attributes controls to change the appearance of the selected axis.
  5. Press the Graph Attributes Dialog's X Ticks button. The application activates the Edit Tick Attributes dialog. Use the dialog's controls to change the appearance of the x axis' ticks and then press the dialog's OK button.
  6. Repeat the same tasks for the y axis, i.e., press the Y Label, Y Axis and Y Ticks buttons. Your graph should now appear similar to the image below.
  7. Finally, press the Attributes dialog's Save button to store your selections into the current document.

See documentation on the XY Graph Dialog for additional details on editing the attributes of xy graphs.

Example: Adding a regression equation
  1. Navigate to the xy graph we created in the first example.
  2. Click the left mouse button on the XY Data Values Section's large table control. The application activates the Edit XY Data dialog.
  3. Select all data rows by clicking the left mouse button on the first row and dragging downward while holding the button down. Alternatively, you can press the dialog's Commands button and select the Select All command from the displaed commands menu.
  4. Press the dialog's Regress button. The application activates the Values Regression dialog. Leave the default values for the Attributes and Y Variable controls. In the X Variables section, select Constant for the A term and X for the B term.

    These selections specify the regression of a straight line, i.e.,

    Y = A + B * X

    Once your selections are made, press the dialog's Regress button. The application will regress the coefficients for the entered equation and display the results in the Regression Coefficients and Regression Statistics tables.

    1
    Select "Constant" for the A term.
    2
    Select "X" for the B term.
    3
    Press the dialog's Regress button to regress coefficients for the selected equation.
    4
    The Regression Coefficients table shows the regressed values for each coefficient in addition to standard error values.
    5
    The Regression Statistics table shows common summary statistics.
  5. Press the dialog's Points button. The application activates the Equation Values dialog. Note that the regressed values fit the data values well.
  6. Press the Equation Values dialog's Copy Values button to copy all the values in the Modeled Values table to the clipboard. Then press the dialog's Done button.
  7. Next, press the Values Regression dialog's Done button.
  8. In the Edit XY Data dialog, click the left mouse button on an empty row after the displayed data values. Then, press the dialog's Commands button and select the Paste data command from the displayed commands menu. The application will paste the modeled values you just copied from the Equation Values dialog into the Data table.
  9. Using the left mouse button, click and drag to select all the newly pasted values. Then press the Set Segs (Set Segments) button. The application activates the Edit Data Segments dialog.
  10. Enter the name "regress" into one of the the New Data Segments controls. Then press the dialog's OK button. The application will assign the new segments to each of the selected data values.
  11. Finally, press the Edit XY Data dialog's Save button to store the updated data values into the current document.
  12. Click the left mouse button on the XY Segments Section's Curve Segments table control. The application activates the Edit Curve Segments dialog.
  13. Select an empty table row and press the dialog's Edit button. The application activates the Edit Curve Segment dialog.
  14. Select "regress" from the list of names in the Segment Name control. Select "No Symbol" as the Symbol Type. Select "Solid Line" as the Line Type and other Line Attributes as desired.
    1
    Select the "regress" segment from the Segment Name control.
    2
    Select "No Symbol" as the Symbol Type.
    3
    Select "Solid Line" as the Line Type.
    4
    Select other Line Attributes, e.g., Thickness or Line Color, as desired.
  15. Press the dialog's OK button. Then, press the Segments dialog's Save button. The new curve segment containing the regressed values will be displayed in the graph using the specified attributes.
Related Documentation
Topic Description
Graph Document the new (released with core 0317) single document that contains chapters for both triangular and xy graphs.
XY Graph Chapter chapter containing functionality for viewing, creating, editing, and analyzing xy graphs.
Triangular Graph Chapter chapter containing functionality for viewing, creating, editing, and analyzing triangular graphs.