Navigation Overview
Applicability: Cranium, Synapse

Cranium and Synapse use a five-level framework to organize all the data, esimation techniques, references, graphs, designs, elements and groups needed for physical property estimation and chemical product design. The five levels of this framework are: documents - chapters - pages - sections - fields.

Navigating Documents

Documents are the topmost structure used to organize information. Each document has a central theme, e.g., there are graph documents, chemical design documents, report documents and bookmark documents.

Documents are typically opened using commands on the File menu. The menu's Open command displays the File Dialog providing commands for finding and selecting a document to open. The File menu also lists several recently opened documents any of which can be reopended by clicking on its name.

Open documents can be found and arranged using commands on the Window menu. Commands are available for arranging open documents in a cascade or tile layout. All open documents are listed at the bottom of the menu.

Navigating Chapters

Each document is divided into several chapters. For example, a knowledge base document contains seven chapters: Summary; Chemicals; Mixtures; Techniques; Groups; Elements; References. A chemical selection document contains four chapters: Summary; Functions; Selections; References. A bookmarks document contains three chapters: Summary; Bookmark Sets; References. Chapters are denoted by tabs at the top of each document.

Navigating Pages

Cranium and Synapse displays each entity on a separate page in a chapter, e.g., all the information for ethanol is displyed on a single page in the Chemicals chapter and all the information on the Tb: Joback Method is displayed on a single page in the Techniques chapter.

Navigating through Cranium and Synapse primarily involves changing chapters and turning pages. Changing pages can be done using commands from the Navigation Menu, buttons found on the toolbar and keyboard commands. (See documentation for the Navigation menu for details on the use of the menu and keyboard commands.)

The navigation controls located in the toolbar enable you to page through all the entities within a chapter.

1
Move to the chapter's first page.
2
Move to the chapter's previous page.
3
Move to the chapter's next page.
4
Move to the chapter's last page.

Using the Go To Dialog

Often the quickest method for going to an entity's page is to look up the entity's name is a sorted list. The Go To dialog enables you to go to an entity's page by selecting its name or other identifying attribute.

For example, in the Chemicals Chapter, selecting the Go To command from the Navigation Menu or pressing ctrl-g on the keyboard will activate the Go To Chemical dialog.

You can type substrings into the bottom edit controls to display only matching names. You can also select a different attribute to display for each entity. For a chemical entity, the attributes you can choose from are:

Beilstein Index CAS Number EC Number
Formula Identifier Merck Index
RTECS Number Synonym

Selecting the entity's attribute and pressing the dialog's OK button will turn to the entity's page in the current document.

Using Bookmarks for Navigation

Bookmarks are lists of documents and pages. For example, the following bookmark set contains a list of chemicals, i.e., pages.

Once you select a bookmark set for a document, you can use the bookmark commands, found on the Bookmarks menu and the toolbar, to navigate through the document. For example, if the previously displayed bookmark set was associated with the current knowledge base, then the First Bookmark command would change to the Chemicals Chapter and turn to the page displaying Acetic acid. This is the first bookmarked page even though it may not be Page 1 of the document.

See bookmark documentation for more details on navigating with bookmarks: Using Bookmarks; Bookmark Chapter; Bookmark Select Dialog.

Navigation to the Next Value

Knowledge bases are well designed for scanning through pages of physical property values. One simply changes to the desired chapter and used the navigation commands described above to page forward or backward.

However, scanning large knowledge bases for values on sparsely populated physical properties will often result in looking over many blank pages. The Next Property Value dialog enables you to turn to the next page that has a value for your particular property of interest.

The Next Property Value dialog is activated by using the Next Value command found on the Navigation menu. Note that the command is only available for the Chemicals and Mixtures Chapters of Knowledge Base documents.

Once activated the dialog enables you to select a property and then scan through the knowledge base for the next entity having values for that property. For example, the image below shows the Next Property Value dialog with the Density, Liquid - f(T) property selected. Pressing the dialog's Next button will display the next chemical having one or more active values for the liquid density. (See documentation for the Next Value Dialog for additional details.)

Tip: Display property of interest first

You should display your property of interest in the current knowledge base before activating the Next Property Value dialog. This is because you will not be able to scroll your document when a dialog is active.

You also do not have to display the same property you are scanning for. You could display the liquid viscosity while use the dialog to search for liquid density values. In this way, you will be able to find chemicals that have both properties.

Related Documentation
Topic Description
Estimating Chemical Properties a short video demonstrating how to estimate the physical properties of pure chemical using either Synapse or Cranium.
Estimating Mixture Properties a short video demonstrating how to estimate the physical properties of mixtures using either Synapse or Cranium.
Getting Started using Cranium provides a quick tour of Cranium's capabilities including physical property estimation and a discussion of structure editing.
Getting Started using Synapse provides a quick tour of Synapse's capabilities including a examples of chemical product design.