Getting Started Using Cranium
Applicability: Cranium, Synapse

Welcome to Cranium !

Cranium is our physical property management and estimation software package. With Cranium, you can store physical property data, generate physical property estimates, capture property estimation knowledge, and diseminate property knowledge into reports, graphs, websites and other chemical software programs.

This page provides a quick tour of some of Cranium's capabilities. Because you will be creating new entities, entering data and estimating properties, it is very important that you create and use a copy of a knowledge base.

Video: Estimating Chemical Properties

Tip: No copying needed in Reader version

The Reader version of Cranium does not allow you to make copies of documents. If you are using the Reader version you can edit the original document. The Reader version does not save any changes.

Example: Create a copy of a knowledge base
  1. Start the Cranium application. Cranium displays a welcome dialog.
  2. Press the welcome dialog’s Done button. Cranium will then display the Open file dialog.
  3. Select a knowledge base and press the Open button. You can choose any of the knowledge bases that come with the Cranium application. Cranium will open and display the selected knowledge base.
  4. Choose the 'Save a Copy' command from the File menu. Cranium displays the Save As dialog.
  5. Choose a location and enter a name for the knowledge base copy, e.g., "MKS Core Knowledge Base - Work".
  6. Finally press the dialog’s Save button.

Cranium will save a copy of the current knowledge base. Use the File menu's Open command to open this new copy.

1
The 'mkskbd' extension denotes a Molecular Knowledge Systems Knowledge Base document.
Tip: Use Save Copy command to make backups

The Save a Copy command is useful for quickly making a backup of your current document. Before you make significant changes to a document, you should consider using the Save a Copy command to make a backup.

Navigation

A knowledgebase is a compilation of information on elements, molecular structures, chemicals, mixtures, estimation techniques and references. Values for the properties of each entity are presented on a single "page" of the knowledge base. These entity pages are arranged into "chapters". The tabs at the top of each knowledge base window correspond to each of these chapters.

Since each entity is displayed on a separate page in a chapter, navigating through Cranium primarily involves changing chapters and turning pages. See documentation for the Navigation Menu for more details on navigation. For more details on the structure of a Cranium document see Cranium Documents.

Example: Change to the Chemicals Chapter
  1. Click the left mouse button on the Chemicals Chapter tab located at the top of the window. Cranium displays a page of the Chemicals Chapter.
    1
    Click on a tab at the top of a window to change chapters.
Example: View chemicals on other pages

The navigation controls located in the toolbar enable you to page through all the entities within a chapter.

1
Move to the chapter's first page.
2
Move to the chapter's previous page.
3
Move to the chapter's next page.
4
Move to the chapter's last page.

  1. Press the toolbar’s right facing, hollow arrow or choose the Navigation menu’s Page Forward command or press the ctrl-f accelerator keystroke. The ctrl-f keystroke is generated by holding down the control key and then pressing the 'f' key.

All three methods are equivalent and result in the display of the next chemical stored in the knowledge base. Navigating to the previous chemical is done by either pressing the toolbar’s left facing, hollow arrow, choosing the Navigation menu’s Page Back command or pressing the ctrl-B accelerator keystroke.

At a chapter’s first page, the commands for paging backward will be disabled. Likewise, at the chapter’s last page, the commands for paging forward will be disabled.

Example: Go to the page displaying a specific chemical
  1. Choose the Navigation menu’s Goto command or press ctrl-g. Cranium displays the Go To Chemical dialog. (See documentation for the All Entities Dialog for more details on the Go To dialog.)
    1
    Attribute, e.g., identifier, synonym, etc., displayed for selection.
    2
    List of entities containing the selection substrings shown below.
    3
    Only entities containing this substring are displayed.
    4
    Only entities containing this substring are displayed.
  2. Type ‘ethyl’ into the first Match Substring edit control and 'hexano' into the second edit control. (Note: leave off the 'l' at the end of hexanol for this example.) Only entities containing those substrings are displayed. Scroll through the displayed list and choose 2-ethy-1-hexanol. The application turns to the page displaying 2-ethy-1-hexanol’s properties. (If you chose to work with another knowledge base that does not contain 2-ethy-1-hexanol, simply choose another chemical.)
Estimating Chemical Properties

One of Cranium’s key capabilities is to estimate physical properties quickly, easily and accurately. To estimate a property Cranium first collects all applicable techniques, sorts them by accuracy, and then tries each one until an estimate is generated.

Example: Estimate 2-ethy-1-hexanol's physical properties
  1. Choose the Compute Estimates command from the Commands menu.
    The application displays the Property Estimation Dialog.
  2. Press the Start button. The application will now estimate each property documenting its progress in the dialog.
  3. Once all estimates have been generated, expand the Boiling Point node, by clicking on the 'plus' sign to the left of the property, and continue to expand all child nodes. The display should appear similar to the following.
    This figure shows that the knowledge base has three estimation techniques that can estimate the boiling point. The first technique tried was the 'Tb: Antoine Equation – PGL2001 [MKS]' technique. This technique failed. The second technique was the 'Tb: Stein + Brown Method [MKS]' technique. This technique succeeded – its estimate is reported at the end of the listing. The third technique was the 'Tb: Joback Method [MK S]' technique. This technique was not tried because an estimate had already been generated.
  4. Click the left mouse button on the 'Tb: Antoine Equation – PGL2001 [MKS]' technique. The dialog’s Details button will become active.
  5. Press the Details button. Cranium displays the Detailed Estimation Results dialog.
    1
    Control showing the detailed results of the estimation.
    The dialog shows that the 'Tb: Antoine Equation – PGL2001 [MKS]' technique failed because it did not have the needed parameters for 2-ethyl-1-hexanol.
  6. Press the Done button to return to the Property Estimation Dialog.
  7. Press the Property Estimation dialog’s Save button. Cranium stores the estimates in the current knowledge base and displays them on 2-ethyl-1-hexanol's page.
    1
    Column of data values.
    2
    Column of estimated values.
    Cranium automatically selects the best applicable estimation technique. At times you may wish to manually specify which technique Cranium should use for a particular property.
Example: Manually specify the boiling point estimation technique
  1. Click the left mouse button on the boiling point field's estimate control. Cranium displays the Estimation Details dialog. This dialog shows the estimated value, the technique used to generate the estimate and comments.
  2. Make a mental note of the estimation tehnique used and then click the dialog's OK button to close the dialog.
  3. Click the right mouse button on the boiling point field’s estimate control. Cranium displays the control’s command menu.
  4. Choose the Select Technique command from the menu. Cranium displays the Estimation Technique Information dialog. The property’s estimation mode is currently set to Automatic Mode. In Automatic Mode Cranium selects the best applicable technique.

    Change the Estimation Mode to Manual Mode and select the Joback Method. (Note: the actutal techniques used and available may differ depending upon the knowledge base you are using. The key concept for this example, is to choose a different technique than the one Cranium automatically selected.)

  5. Press the dialog's OK button. Cranium will now use the Joback Method the next time it estimates the normal boiling point.
  6. Note 2-ethyl-1-hexanol's currently estimated boiling point. Use the previous procedure to estimate the chemical’s properties again. Note how the boiling point estimate has changed.
Example: Estimate the vapor pressure at several temperatures

Cranium also estimates temperature and pressure dependent properties. To estimate such dependent properties, you must first enter temperature and pressure values.

  1. Scroll down to the data pane’s Temperature Dependent section.
    1
    Property control.
    2
    Values type control.
    3
    Field's table control.
  2. Click the left mouse button in the property control, i.e., the control to the right of the "Property:" label. Cranium displays the Properties dialog. This dialog lists all the temperature dependent properties currently known to Cranium.
    1
    Properties list control.
    2
    Values type control.
  3. Select Vapor Pressure, Liquid – f(T) in the Properties list control and Estimates from the Values Type control. Then press the OK button.
You must now enter the temperatures for which you want estimates generated.
  1. Click the left mouse button within the Temperature Dependent field's table. Click in the white, grid area of the table not in the column headings or row labels. Cranium displays the state variables edit dialog.
  2. Double click the left mouse button in the table’s first row. Cranium displays another edit dialog. Enter a value of 298 K in this dialog and press the OK button.
  3. Click and hold the left mouse button in the table's second row. Cranium will highlight the row.
  4. Drag the mouse downward to the fifteenth row and release the mouse button. Rows two through fifteen will now be highlighted.
  5. Press the Series button. Cranium will display the Temperature Series dialog.
  6. Enter 100 C for the Starting temperature. Change the temperature option to Temperature Increment and enter a value of 5 C. (For now, if the temperature units are set to a value other than C, enter the corresponding temperature value in the current units. See the documentation for the Set Property Units dialog for details on changing property units.)
  7. Press the OK button. Cranium will generate a series of temperature entries starting at 100 C and being incremented by 5 C.
  8. Press the Save button in the edit dialog. Cranium stores the entered temperatures in the knowledge base and redisplays the Temperature Dependent field's table.

Temperature dependent estimates can now be generated as done previously. However, for this example you will only generate vapor pressure estimates.

  1. Click the right mouse button within the Temperature Dependent field's table. Click in the white, grid area of the table not in the column headings or row labels. Cranium displays the field's commands menu.
  2. Choose the Compute Estimates command from the menu. Cranium will display the property estimation dialog.
  3. Press the Start button. Cranium will estimate the vapor pressure for each temperature value.
  4. Press the Save button to have Cranium store the estimated values in the knowledge base.
Example: Add a new chemical

One of the advantages of an electronic reference book over a printed one is the ease with which pages can be added and removed.

  1. Using the tabs at the top of the document, change to the Chemicals Chapter by clicking the left mouse button on Chemicals tab.
  2. Press the Add toolbar button (the large plus sign). Alternatively you can choose the Add Page command from the Edit menu or use the crtl-a keyboard accelerator.
    1
    Add Button: pressing this toolbar button will add a new, blank page to the current chapter.
    2
    Delete Button: pressing this toolbar button will delete the current page from the current chapter. IMPORTANT: the deletion of a page cannot be undone.
Example: Enter a name for our new chemical
  1. Click the left mouse button in the identifier’s field data control.
    1
    Identifier's field data control.
    Cranium displays the Chemical Identifier's edit dialog.
  2. Type in a name for our new chemical. You can also add a reference and comments. (See the documentation for the Text-Reference Edit Dialog for details on editing.)
  3. Press the Save button. Cranium will store the values in the knowledge base and display the new name in the chemical's identifier field.
Editing Molecular Structure

Many estimation techniques require knowledge of a chemical's molecular structure. Some techniques require only information about the chemical's family, e.g., is the chemical chlorinated. Other techniques, e.g., group contribution techniques, require a chemical's structure to be completely dissected into molecular fragments.

Cranium uses a simple connectivity model to represent molecular structure. Atoms and bonds are connected into a simple graph.

Example: Enter a molecular structure for our new chemical
  1. Scroll the data pane to the Chemical Structure section, located near the top of the pane, and click the left mouse button in the Structure field. Cranium displays the molecular structure edit dialog.

    The tool buttons on the dialog's left are used to change drawing modes. The controls at the dialog’s top are used to specify the current element and the current bond type. The large central window is the canvas on which you draw your structure.

  2. Press the Atom button (the large A). Cranium now adds an atom wherever you click the mouse in the canvas pane.
  3. Move the mouse onto the canvas pane and click the left mouse button several times in several different locations. Cranium creates and adds several new carbon atoms.
  4. Cranium uses the current element, specified at the dialog's top, to create new atoms at the location of your mouse click. Click the left mouse button on the elements control. Choose Oxygen from the list of available elements.
  5. Click the left mouse button on the canvas pane to add a new oxygen atom.
  6. As you add each atom, Cranium adds the appropriate number of assumed hydrogens. Cranium automatically updates the number of assumed hydrogens as you bond atoms together.
  7. Press the Bond button (the diagonal line). Cranium is now ready to create bonds between atoms.
  8. Click the left mouse button on the first atom to be bonded. Cranium redraws the atom in green and surrounds it with four small, solid rectangles.
  9. Click the left mouse button on the second atom to be bonded. Cranium creates a bond of the currently selected bond type and attaches it to this atom and the first bonding atom.
  10. The current bond type is changed using the bond type control located at the top of the dialog. Click the left mouse button on the bond type control. Cranium displays a list of available bond types.
  11. Choose the Double Bond type from the list.
  12. Continue the process, selecting pairs of atoms to bond, until all atoms are bonded.
  13. You have now completed editing your new structure. Press the Save button. Cranium will store the structure in the knowledge base and redisplay it in the structure field. (See documentation for the Structure Edit Dialog for details on editing molecular structure.)

You can now use the Commands menu Compute Estimates command to estimate the properties of the new structure.

Related Documentation